Run case wont work« Back to Questions List

When i hit the Run Case button on the gui i got an error message that says: File "MFlow_MVRC.py", line 1691, in run_case KeyError: 'local_DockerToolbox' Maybe i'm missing something but i couldnt find what so decieded to ask it away.
Posted by Pure Power Racing
Asked on June 22, 2017 08:53
0

I think to have solved the issue. In one or two days I will upload a new version of MantiumFlow.

Posted by MCAE Support
Answered On June 26, 2017 16:44
0

Getting this when creating the case:

https://pasteboard.co/1S0lbcHA4.png

Sadly it didnt change anything, still same error.

Posted by Pure Power Racing
Answered On June 26, 2017 16:43
0

It throws an invalid field warning on loading the case.

Posted by Idadox
Answered On June 26, 2017 10:26
0

Can someone please add the following line into the default_settings.ini and confirm if that solves the issue:

local_DockerToolbox=C:\Program Files\Docker Toolbox

Posted by MCAE Support
Answered On June 26, 2017 09:32
0

The same error as stated on the OP here.

I can’t find where to edit the shared folder, there was something about it, right?

And the OF install points to the installation root. Below it a folder called 1606 and nothing else. Is this the right point?

Posted by Idadox
Answered On June 23, 2017 23:51
0

Status update 2:

I managed to run it manually via command prompt. So there is definitely something missing or wrong on the gui side.

Posted by Pure Power Racing
Answered On June 23, 2017 16:14
0

I managed to get the 1606+ working but as i said, new software still gives the same error.

Posted by Pure Power Racing
Answered On June 23, 2017 15:52
0

You should definitively be using OF v1606+. The newer version will not work as many post-processing related things have changed. Try to uninstall everything and then follow these instructions:
https://mantiumchallenge.com/installation-instructions-install-openfoam-v1606-windows/

Posted by MCAE Support
Answered On June 23, 2017 05:31
0

Status update:

After trying the samething over and over like a mad man, i fixed the openfoam errors but unfortunately the new software still gives that ” KeyError: ’local_DockerToolbox’ ” error

Posted by Pure Power Racing
Answered On June 23, 2017 03:04
0

Well somehow i managed to escalade the problem and corrupt my openfoam. I downloaded and tried both 1612+ and 1606+ but after running the OF_Env_Create as administrator, virtual box doesnt run the default virtual machine and gives error codes like this:

Failed to open a session for the virtual machine default.The VM session was aborted.Result Code: E_FAIL (0x80004005)Component: SessionMachineInterface: ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}

Posted by Pure Power Racing
Answered On June 23, 2017 01:48
0

I tried to look into but I can’t get into the settings page.

Only the Apply button before opening a case.
Nothing after opening the case.

W10

Posted by Idadox
Answered On June 22, 2017 20:42
0

Hm, I not really sure how to do it in Windows either. Maybe someone else can help. You could try using the old GUI just to see if that one will do the trick of starting the simulation.
But I would assume that the Windows OF version has some kind of command prompt. If it does open it, head over to your case and execute the runCase script.

Posted by MCAE Support
Answered On June 22, 2017 19:40
0

Can you explain me the commands? I didnt use any commands since the gui came out for the previous software so apperantly i forgot the dos commands.

Posted by Pure Power Racing
Answered On June 22, 2017 17:51
0

Can you execute the command manually?

Posted by MCAE Support
Answered On June 22, 2017 16:31
0

It’s set at the default path wich is the correct one. Im using Windows 10 btw.

Posted by Pure Power Racing
Answered On June 22, 2017 15:32
0

Did you enter the correct path in the MantiumFlow configuration file?
When using the GUI you can find it by clicking the MantiumCAE logo in the lower right corner and then on configuration.

Posted by MCAE Support
Answered On June 22, 2017 08:57