Solver trying to find stl n wrong side« Back to Questions List

Or so it's waht I understand from the log. Shouldn't the right side be ignored? ######### faceSource faceSource_engine_in_R_014: total faces = 139 total area = 0.0080436009 faceSource faceSource_exhaust_R_009: total faces = 118 total area = 0.0055021553 [2] [2] [2] --> FOAM FATAL ERROR: [2] faceSource faceSource_engine_in_L_014: patch(engine_in_L_014): Unknown patch name: engine_in_L_014. Valid patch names are: 26 ( auto_wt_side auto_wt_sym_plane auto_wt_inlet auto_wt_outlet auto_wt_floor auto_wt_top engine_in_R_014 exhaust_R_009 G_FwdGurney30_000 REG_cfd_parts_suspension_plus_front_100mm StreaksF000 G_MidGurney44_000 rw_ME_be122125_C HX_R_001 Fins000 REG_cfd_parts_wheel_FrontRight bodyFull_014 FW_SE_BE122185_000 REG_cfd_parts_wheel_RearRight G_RwingGurney_13_000 StreaksR000 ExBaffle_R_000 procBoundary2to0 procBoundary2to3 procBoundary2to4 procBoundary2to6 ) ###########
Posted by Idadox
Asked on June 27, 2017 21:29
0

Redid the surface and got the same error. There are some offending points with y crossing 0 by around 1mx10^-11.
All fix it by hand, but can you ease the tolerance a bit?

Posted by Idadox
Answered On June 28, 2017 13:49
0

Is fixed. the new version will probably get released today.

Posted by MCAE Support
Answered On June 29, 2017 09:03
0

Thanks!

Posted by Idadox
Answered On June 29, 2017 09:40
0

Reposting the log to get it readable:

faceSource faceSource_engine_in_R_014:
total faces = 139
total area = 0.0080436009

faceSource faceSource_exhaust_R_009:
total faces = 118
total area = 0.0055021553

[2]
[2]
[2] –> FOAM FATAL ERROR:
[2] faceSource faceSource_engine_in_L_014: patch(engine_in_L_014):
Unknown patch name: engine_in_L_014. Valid patch names are:
26
(
auto_wt_side
auto_wt_sym_plane
auto_wt_inlet
auto_wt_outlet
auto_wt_floor
auto_wt_top
engine_in_R_014
exhaust_R_009
G_FwdGurney30_000
REG_cfd_parts_suspension_plus_front_100mm
StreaksF000
G_MidGurney44_000
rw_ME_be122125_C
HX_R_001
Fins000
REG_cfd_parts_wheel_FrontRight
bodyFull_014
FW_SE_BE122185_000
REG_cfd_parts_wheel_RearRight
G_RwingGurney_13_000
StreaksR000
ExBaffle_R_000
procBoundary2to0
procBoundary2to3
procBoundary2to4
procBoundary2to6
)

Posted by Idadox
Answered On June 27, 2017 21:33
0

Hi,
MantiumFlow tries to check which parts will be part of the simulation. There are thresholds to do so. You are almost right, we only look at the side with positive Y. This is the right hand side. Somehow MantiumFlow thought that your part engine_in_L_014 will be part of the simulation. To determine what parts are inside of the domain the algorithm works with certain tolerances. You know that a part can sometime slightly overlap the Y=0 plane and so on. In your case the tolerance settings were maybe not quite right. You can send me the case so I can check if I should adjust them.

Posted by MCAE Support
Answered On June 28, 2017 08:59
0

I have re-imported the offending part and it reads exact Y=0.000 on all border points. Also checked it within Magics, y=0.000.

I did submit the case file yesterday, 17m0014.rar.

Posted by Idadox
Answered On June 28, 2017 09:17